Woocommerce to Quickbooks Solution | InfinitySync

WooCommerce has long been the king of the eCommerce kingdom. With 42 percent of online stores using the WooCommerce plugin – six times the number of stores using Shopify – the plugin’s dominating reign shows no signs of a coup any time soon.

WooCommerce’s simple installation process and flexible design gives even neophytes the power to create online shops that promote sales and enhance their brands. Its domain encompasses a mobile-friendly structure, an unlimited number of products and product categories, and a promise of complete control over your data. Serving as the king’s right hand, third-party developers like InfinitySync further facilitate WooCommerce’s supremacy.

That said, even the most perfect of kingdoms has the occasional plague: technical complications that can leave you feeling like a dunce. Thankfully when it comes to WooCommerce, the symptoms typically aren’t quite so bubonic. Most WooCommerce issues are caused by:

  • Out of date website software,
  • A conflict with your theme or
  • A conflict with another plugin.

Before burning your WooCommerce store to the ground, it’s best to check if there are updates available for your website. Up-to-date software not only protects your website from hacks but can also resolve symptoms you might be exhibiting through bug fixes found in the latest versions of WordPress, WooCommerce and Woo plugins.

BROAD-SPECTRUM TREATMENT: Update Plugins, WooCommerce, Themes and WordPress

First and foremost, you always want to make a complete backup of your website – and yes, that means backing up your database and files too. While this may seem like a no-brainer, it would be negligent not to state its importance. The amount of time it takes to backup pales in comparison to what it would take to rebuild if something goes away.

Secondly, it’s best to update plugins before performing any WooCommerce updates. If your store is running on WooCommerce 2.0 or earlier, update on a test or staging site to ensure the WooCommerce update is successful.

To update your website, go to WooCommerce > System Status. Important updates will be highlighted in red.

To update your plugins, go to WordPress Dashboard > Plugins > Update Available. Update all third-party plugins, excluding WooCommerce.

Then, to update WooCommerce, go to WordPress Dashboard > Plugins and update WooCommerce to the latest version.

If WordPress needs to be updated, there will be a notification on your WordPress Dashboard.

Finally, to update your theme, go to WordPress Dashboard > Updates > Update Themes. If your site uses a WooTheme, go to WordPress Dashboard > Theme > Update Framework.

AN UNDERLYNING CONDITION

If you’re still experiencing complications with your WooCommerce store after updating your site, there could be any number of things going on. One of the most common causes for error is if one of your plugins is not compatible with your theme.

The best way to determine if this is the case is to disable all of your plugins and re-enable them one by one to see if one (or more) of your plugins is incompatible with your theme.

Likewise, your theme could be, to continue the earlier metaphor, patient zero. While most third-party themes are compatible with WooCommerce, some are not. To make sure your theme works with WooCommerce, change your theme to WordPress’ default theme. If the problem is fixed, that means your chosen third-party theme is not compatible with WooCommerce.

COMMON WARNING SIGNS AND SYMPTOMS

Conflicting Sessions

If you host multiple WordPress sites on a single domain, you may experience conflicting sessions. If this is the case, open your wp-config.php file and add the following code:

if ( ! session_id() ) {

session_name( ‘PHPSESSID_1’ );

}

You can change the session name to identify each install.

session_start Warning

If you receive the following error message, the issue is on your hosting provider’s end:

Warning: session_start() [function.session-start]: open(xxx) failed

Unfortunately, this means that the sessions directory is not writeable or that PHP sessions did not setup correctly. You will need to contact your hosting provider for support.

Call to Undefined Function: is_woocommerce_active()

This error message can be caused by an out-of-date plugin or a third-party theme. If you have already updated your plugins and you’re still receiving this error message, then your theme is at fault. To solve this issue, switch your theme to Twenty Sixteen and activate the plugin. After it’s activated, you can switch back to your chosen theme.

There are plenty of reasons why WooCommerce is the king of eCommerce, but its flexibility and ease of use definitely support the crown. While error messages and issues with your online shop can be frustrating, there’s typically a simple solution to get your WooCommerce store back up and running in healthy condition. To diagnose any problems or errors not discussed above, search the Docs or contact the WooCommerce support minions.

Leave a Reply